Friday, October 19, 2007

Internet Explorer 7 BAH HUMBUG$#%#%!!

Well, why am i ranting?

Easy, i am just adding salt to the wound about the oddities of Internet Explorer.

After reading THIS at MerDurian "About how to change your icon for your blog", i tried to change my blog Icon, found an icon i liked and prompty tried my best to do as what she have posted in her blog.

Well first of all, the code had a bit of an error :P sorry MerDurian, the ending of the code for the icon tag should be /> instead of /&g hehehe, but nevertheless, i got it working properly.

Or i thought i did, I was so happy that i can see the icon on my own webpage (I'm using Mozilla Firefox) so i let my wife know about it, ask her to load my page to see my new icon. Well she did, but she said it's still the blogger icon.

I was like "what??" mine is loading my little mushroom icon. So i asked her what browser she was using, and she replied IE. HMMMMMMMMMMMMMMM!!!!! I googled it up, and found out quite some people already have the same problem, that IE cannot read the file properly.

There was a workaround though (ONLY FOR IE 6) you have to add the webpage to your favourites for the icon to register. Then when you load the page, the icon will come out altogether. But it doesn't work for IE7.

Even after you add the blog page to favourites, the icon appears in your favourites, but when you select the page from your favourites, the icon still doesn't load with your blog address. I was worked up now. I tried to search left right up down in google thinking there has to be a workaround. In the end, i had to give up, bah, nevermind, i don't use IE anyway, except for some lousy office applications which need IE to launch :P

I think i wasted 4 unproductive hours doing that, ah well...

UPDATE : After a day of not touching it, suddenly IE7 shows the icon too.....???????? Takes so long to update meh??

Technorati Tags:, , , , , , , ,

10 comments:

melvin,foong said...

Did you try clearing your cache?

B@m®©™ said...

yep, i went into IE deleted all the files online/offline/cache and all, and refreshed the page, nothing, my wife did the same, nothing, i did it at my home pc, nothing, still the B logo, but today when i come to work, my wife told me today can liao....ah well

Jasonmumbles said...

Ditch IE6/7 for good. :D

B@m®©™ said...

hahaha, i did, but but, like i said, there's some apps which still have to work on IE, like some bank sites work better in IE, even maxis site is like that

mercury said...

ahah thank you for telling me.. its really have an error
btw, i really got no comment about IE at all.... since I used FireFox long time ago

twosuperheroes said...

hehehe, nice dont use IE ( although I need to use it when I am in CC ).. ahha.. firefox is the best ... erm, like wanna learn it from u.. catch u back later on how to that k :D... thanx :D

B@m®©™ said...

no problemo, just mail me or leave me a message :)

babe_kl said...

eh i still see B logo for yr site wor??

B@m®©™ said...

hmm mebe u gotta clear cache, but at home all i can see liao....

Jase Lee said...

My blog has problem with IE7. Should have placed a warning: "Reading my page in IE will result in massive brain damage."